2

A Suggested edit alert popped up moments ago. When I clicked it I saw that the queue was cleared, which is fine.

enter image description here

The problem is, it is not going away. I have refresed and refreshed, the alert is still there even after switching communities and coming back. I have even tried closing the tab and reopening my history SE page. The alert simply won't go away.

I am using Google Chrome Version 50.0.2661.102 (64-bit) for Mac running OS X v10.11.3 El Capitan. The issue is appearing only on History SE, not on any of the other communities.

UPDATE 1: 1 hour (Maybe more) after taking the screenshot, the alert is still there.

UPDATE 2: Almost 22 hours after posting this, it has stopped appearing.

UPDATE 3: The alert is showing again with similar behavior. It happened after I suggested a tag excerpt edit. You can see the time and rep change that this issue is reproducing again.

enter image description here

UPDATE 4: The alert has again vanished this morning.

1

No this is a known caching issue and .

Quoting Shog's answer:

Caching. And some complicated eligibility rules.

Most of the time, the top bar will indicate what's still TO DO for the site, while the numbers under /review will indicate what's still TO DO for you. But when reviews are being done quickly, they can become out-of-date briefly. The system recalculates them every few minutes, so generally they won't be out of date for too long...

...But there are still some edge-cases where there'll be items in a queue that you aren't eligible to review but which are disqualified because of tests too expensive for the system to run until/unless you actually try to review them.

It's unlikely you'll encounter the latter very often, but if you see a discrepancy hanging around for more than 5-10 minutes, chances are that's what it is.

So what happened is, the topbar showed that a review was pending for the site to do. When you clicked it, System calculated your eligibility for the review and found out that you are not eligible for that review (Because it's your edit after all). So it showed you no pending edits.

Also see: Another one of Shog's answers here.

Further reading: Should I blame Caching?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .