5

In my answer to the question How do archaeologists date cave paintings?, the hyperlinks are not working. Instead, it shows up like this (for example):

enter image description here

and this:

enter image description here

I've tried editing again but the problem persists. Thinking that the problem might be the answer sort of 'crashed' because of too many links, I removed some of non-essential ones but this hasn't worked either. Also, I googled the problem but came up with nothing that seemed related, and nor does there seem to be a limit on how many links can be put in answer.

Can anyone help me on how to fix this problem?

2 Answers 2

6

The link parser gets confused by the following link:

https://en.wikipedia.org/wiki/Radiocarbon_dating#:~:text=Radiocarbon%20dating%20(also%20referred%20to,a%20radioactive%20isotope%20of%20carbon.

A 'working link' reads:

https://en.wikipedia.org/wiki/Radiocarbon_dating#:~:text=Radiocarbon%20dating%20(also%20referred%20to,a%20radioactive%20isotope%20of%20carbon) notice the last character: a closing bracket.

The correct link however reads:

https://en.wikipedia.org/wiki/Radiocarbon_dating

Everything after the 'dating` and including the #-sign is just added junk some newer browsers add when copying a link.

Starting with #:~:text=R…

In this case it gets worse because there is an unmatched opening bracket. Either remove that link-junk altogether or add a matching closing bracket.

Those snippets should always be removed when adding a link to a post.

Cleaning up this one broken link for the post in question fixes the remaining links. There are still links in that post with link-junk (eg Smithsonian, No9).

A Minimal (non-) Working example

To demonstrate:

Link as posted in answer with added bracket.

Link posted in correct form, that is cleaned up.

Link with just hash tag added.

[Link with unmatched bracket.][4]

Solution

Always clean up those pesky links when your modern browser gets too clever by inserting some crap.

We had quite a lot of those chatty link-junk links added recently. If you edit any post and spot them: destroy them on site (sic", also on sight ;).

That a single link which the parser cannot read then destroys all subsequent ones is of course worthy of a bug report; to browser developers as well as MetaSE.


The remaining text here is left over from junk inclusion:

[4]: https://en.wikipedia.org/wiki/Radiocarbon_dating#:~:text=Radiocarbon%20dating%20(also%20referred%20to,a%20radioactive%20isotope%20of%20carbon. [5]: https://history.stackexchange.com/help

2
  • 2
    Thanks for this. Your explanation is commendably clear and concise. Dec 3, 2020 at 0:39
  • 1
    @LarsBosteen The 'junk' is often the result of a previous search text done in Google and will highlight that text when the page is opened. This is, in most cases, not needed at all. Dec 4, 2020 at 9:31
5

It looks like the first 5 links somehow got deleted from the text, but not from the list of links. You'll notice the first "missing link" in the text is [6] rather than [1].

I don't know if its that (perhaps since there's no [1] in the text, it doesn't think the later [1] at the bottom is a link list?), or if there's something messed up in one of those first 5 links (like a character it doesn't like?), but if I delete the first 5 links at that list at the bottom, the rest show up as links.

6
  • Thanks, and I've done as you've suggested. The hyperlinks are now showing but the first number is still [6]. I thought that this was supposed to change automatically.... Do you know if this was caused by too many links, or is there some glitch in the system? Dec 2, 2020 at 4:07
  • 2
    @LarsBosteen It seems the original glitch happened due to the URL containing the search result highlight cues (#:~:text=Radiocarbon%20dating%20(also%20referred%20to,a%20radioactive%20isotope%20of%20carbon.) - adding this link breaks the parser. When I added the wiki link (without that string) back into your latest revision, the parser did automatically resort the order of the extant links.
    – Semaphore
    Dec 2, 2020 at 7:36
  • 1
    @Semaphore Thanks for that info / analysis, and a big thanks for taking the time to insert the links in my answer. Very much appreciated! Dec 2, 2020 at 9:12
  • 1
    @Semaphore While I really dislike this new trend of many browsers to add this junk to copied URLs: In this case it is probably not the sheer presence of this junk or sheer length causing the glitch [Sidenote: 'length itself' is not the problem, again ;) ]. Only removing the one part of that one first URL in brackets fixes it as well. Those brackets are the problem. But I agree that the junk should probably avoided as much as possible. I asked about that in chat a while ago. Dec 2, 2020 at 9:33
  • 1
    @LаngLаngС Ah, I see. Yes that would make sense considering it's missing a closing bracket.
    – Semaphore
    Dec 2, 2020 at 10:05
  • Likely it can't deal with that '#' symbol in a link
    – T.E.D. Mod
    Dec 2, 2020 at 14:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .