0

When I try to upload this image as part of a question, I am told Failed to upload image; the format is not supported:

https://commons.wikimedia.org/wiki/File:The_Royal_Navy_during_the_Second_World_War_A24702.jpg

Same after I download it, and same after I convert it to PNG.

Is there some new rule that forbids images of this size/format/something, or is it a bug with the server, or a bug with me?

1

I don't know if this is the reason, but that is a very large picture, and it would not look very good in an answer or question here. The SE software does not scale pictures currently, and that one is considerably larger than will fit on a typical browser window. Try one of the smaller sizes available instead.

  • The screenshots I post to StackOverflow get resized if they are too wide: stackoverflow.com/questions/15267950 But now that I check, they are only HTML-resized, so indeed it seems that there is no server-side resizing. – nic Mar 16 '13 at 11:16
  • Uploading a resized picture worked (actually I used the i.stack.imgur.com/OyBzv.jpg URL found in coleopterist's answer) – nic Mar 18 '13 at 3:49
0

I'm not sure why you tried to upload the image. You can simply choose "Add image (from the web)", add the URL of the image (the direct URL of the jpeg rather than the URL in your OP which is an HTML page), and click Add picture. That did it for me as you can see below.

enter image description here

For the direct URL, I right-clicked on the image and chose Copy image URL (in Chrome).


Edit: Based on Darek's comments, this might have been a temporary bug with SE. It appears to have been fixed now.

  • 1
    I've tried it both ways (Opera) after the question was asked and it didn't work. – Darek Wędrychowski Mar 17 '13 at 17:31
  • @DarekWędrychowski and how about now? – coleopterist Mar 17 '13 at 17:33
  • Somehow it works now, with the same picture. :) – Darek Wędrychowski Mar 17 '13 at 17:35
  • @DarekWędrychowski Then, I guess it was an SE bug. – coleopterist Mar 17 '13 at 17:36
  • "Add image (from the web)" does not work either. It must be an SE bug. I just tried now, the bug is still present. – nic Mar 18 '13 at 3:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .